This page describes the V1.2 and later versions of pcdMagic. For earlier versions, see the manual for version 1.1


The Windows


There are two key windows:

  • The browser window, which presents a list of images. Note that the browser window can only browse folders that you have explicitly opened, or sub-folder of folders that you explicitly opened via the "open dialog". To go to a new folder, click the Folder icon in the top left corner of the window
  • The develop window, which allows you to view and manipulate a single image. pcdMagic allows you to have multiple develop windows open at the same time, subject to available memory. You open a new develop windows by clicking an image in the browser, or by opening an image from the File menu.

In addition, there are subsidiary windows to display EXIF information, to manage camera profiles, and to manage presets.


Opening Base64 images


Base64 images are special high resolution versions of Photo CD images. They only exist on CD's marked as "Photo CD Pro". Opening these images requires that the entire contents of the original CD be available to pcdMagic, not just individual *.pcd files. For more information, see the page on Base64 images.


Adjusting Images In The Develop Window


  • To zoom in and out, use the ⌘+ and ⌘- keys, or use the View menu.
  • To zoom to a specific zoom ratio, use ⌘F to fit the image in the window, or ⌘1, ⌘2, ⌘3 or ⌘4 for 100%, 200%, 300% or 400% zoom ratios.
  • To pan the image, click, hold and drag or use a two-finger scroll on a trackpad.
  • Sliders can be adjusted with with the cursor or the stepper controls. Also, when you're in a text box, you can use the arrow keys, shift arrow keys and page up/page down keys to change control values.
  • To reset a slider to its default value, double-click the text above it.


How to Crop Images


You can crop images by simply by selecting crop mode, and dragging the corners of the crop area.


Using Scanner Profiles


Normally the color profile is set automatically based on the metadata included into the image to match the film and scanner type. However, you can override the automatic setting by using the Color Profile drop-down menu.


Note that by default, only pcdMagic's internal color profiles are displayed for selection. However, you can chose to display all profiles installed on your system as well by changing the Preferences settings. This allows you to, for example, use the original PCD Kodak profiles if you have them available.


Using Presets


Presets are an important part of pcdMagic:

  • To create a preset, click "New Preset" in the develop window. You can then chose which of the current image settings to use as part of the preset.
  • In order to manage presets, go to the File->Manage Presets... menu.


Exporting


pcdMagic allows you to export in JPEG, TIFF or DNG format. JPEG images are exported in the sRGB color space, while TIFF and DNG images use ProPhoto.


Batch Operations


You can batch process images from the Browser Window:

  • Select the location for the processed files in the drop down menu.
  • Select all the images you want to process in the browser window. Simply use shift-click or cmd-click to select multiple files.
  • Click the action menu on the bottom left of the Browser menu, and select the preset to use in the processing. 

You can set pcdMagic to either overwrite existing files with the same name as batch processed files, or to create new names in AccuRaw->Preferences. New names are formed by adding "_n" to the existing name, e.g., "photo.pcd" will be exported as "photo_1.jpg" if "photo.jpg" already exists. 


Integration with Other Applications


pcdMagic will work together with other apps as an external editor. For more information, see the page on App Integration.